Which browsers are compatible with 360Learning?

The 360Learning application is accessible on tablets and computers via the following browsers:

  • Internet Explorer 8 and more recent versions
  • Firefox 3.6 and more recent versions
  • Google Chrome 5 and more recent versions
  • Safari 3.5 and more recent versions

If your browser is too old, you have 2 possible solutions:

  1. You can download a more recent version yourself. In this case, click on the browser you use in this list and download the latest version:
  1. You do not have the rights required to update your software. In this case, please contact your network administrator so that he/she can perform the appropriate task(s). Make sure you specify in your request that the version of your PC's web browser is too old to allow the use of your digital training tool, 360Learning.
Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request